[patch]: fix the obsolete usage of AC_OUTPUT
While implementing the Lua DPI I saw that configure.in uses AC_OUTPUT in an obsolete way. This patch changes it to use the modern calling convention. (It also puts each of the generated files on a separate line, which makes it much easier to read patches that modify that list.) Regards, Jeremy Henty
Bump? Is this OK? Personally I think it's a no-brainer but I didn't to change the build system in any way without feedback. Please comment. Regards, Jeremy Henty On Sun, Nov 28, 2010 at 05:06:17PM +0000, Jeremy Henty wrote:
While implementing the Lua DPI I saw that configure.in uses AC_OUTPUT in an obsolete way. This patch changes it to use the modern calling convention. (It also puts each of the generated files on a separate line, which makes it much easier to read patches that modify that list.)
Regards,
Jeremy Henty
# HG changeset patch # Parent d21e2c45d0f9a2e1a6bb718132f948d48f619a73 configure.in: fix the obsolete usage of AC_OUTPUT.
diff -r d21e2c45d0f9 configure.in --- a/configure.in Sun Nov 28 08:07:52 2010 +0000 +++ b/configure.in Sun Nov 28 16:52:48 2010 +0000 @@ -511,5 +511,18 @@ AC_SUBST(LIBICONV_LIBS) AC_SUBST(datadir)
-AC_OUTPUT(Makefile dlib/Makefile dpip/Makefile dpid/Makefile dpi/Makefile doc/Makefile dw/Makefile lout/Makefile src/Makefile src/IO/Makefile test/Makefile) +AC_CONFIG_FILES([ + Makefile + dlib/Makefile + dpip/Makefile + dpid/Makefile + dpi/Makefile + doc/Makefile + dw/Makefile + lout/Makefile + src/Makefile + src/IO/Makefile + test/Makefile +])
+AC_OUTPUT
On Thu, Dec 02, 2010 at 01:08:54PM +0000, Jeremy Henty wrote:
Bump? Is this OK? Personally I think it's a no-brainer but I didn't to change the build system in any way without feedback. Please comment.
It looks OK to me. Especially after reading the AC_OUTPUT section in http://www.gnu.org/software/hello/manual/autoconf/Obsolete-Macros.html#Obsol... I'd say: commit, and let's see whether a hidden issue arises.
On Sun, Nov 28, 2010 at 05:06:17PM +0000, Jeremy Henty wrote:
While implementing the Lua DPI I saw that configure.in uses AC_OUTPUT in an obsolete way. This patch changes it to use the modern calling convention. (It also puts each of the generated files on a separate line, which makes it much easier to read patches that modify that list.)
Regards,
Jeremy Henty
# HG changeset patch # Parent d21e2c45d0f9a2e1a6bb718132f948d48f619a73 configure.in: fix the obsolete usage of AC_OUTPUT.
diff -r d21e2c45d0f9 configure.in --- a/configure.in Sun Nov 28 08:07:52 2010 +0000 +++ b/configure.in Sun Nov 28 16:52:48 2010 +0000 @@ -511,5 +511,18 @@ AC_SUBST(LIBICONV_LIBS) AC_SUBST(datadir)
-AC_OUTPUT(Makefile dlib/Makefile dpip/Makefile dpid/Makefile dpi/Makefile doc/Makefile dw/Makefile lout/Makefile src/Makefile src/IO/Makefile test/Makefile) +AC_CONFIG_FILES([ + Makefile + dlib/Makefile + dpip/Makefile + dpid/Makefile + dpi/Makefile + doc/Makefile + dw/Makefile + lout/Makefile + src/Makefile + src/IO/Makefile + test/Makefile +])
+AC_OUTPUT
_______________________________________________ Dillo-dev mailing list Dillo-dev@dillo.org http://lists.auriga.wearlab.de/cgi-bin/mailman/listinfo/dillo-dev
-- Cheers Jorge.-
On Thu, Dec 02, 2010 at 11:28:51AM -0300, Jorge Arellano Cid wrote:
On Thu, Dec 02, 2010 at 01:08:54PM +0000, Jeremy Henty wrote:
Bump? Is this OK? ...
It looks OK to me. Especially after reading the AC_OUTPUT section in http://www.gnu.org/software/hello/manual/autoconf/Obsolete-Macros.html#Obsol...
I'd say: commit, and let's see whether a hidden issue arises.
OK, I'll hang on to it over the weekend and then push it if there are no other comments. Regards, Jeremy Henty
Jeremy wrote:
On Thu, Dec 02, 2010 at 11:28:51AM -0300, Jorge Arellano Cid wrote:
On Thu, Dec 02, 2010 at 01:08:54PM +0000, Jeremy Henty wrote:
Bump? Is this OK? ...
It looks OK to me. Especially after reading the AC_OUTPUT section in http://www.gnu.org/software/hello/manual/autoconf/Obsolete-Macros.html#Obsol...
I'd say: commit, and let's see whether a hidden issue arises.
OK, I'll hang on to it over the weekend and then push it if there are no other comments.
I had looked at the docs and it seemed all right to me as well, but of course I'm no autoconf expert either.
participants (3)
-
corvid@lavabit.com
-
jcid@dillo.org
-
onepoint@starurchin.org