10 Nov
2009
10 Nov
'09
11:03 p.m.
On Tue, Nov 10, 2009 at 05:48:12PM -0300, Jorge Arellano Cid wrote:
On Mon, Nov 09, 2009 at 08:00:43PM +0100, Johannes Hofmann wrote:
PS: While looking at the code I found that Dpi_make_socket_fd() could be simplified to just:
return socket(AF_INET, SOCK_STREAM, 0);
Yes, it was coded that way to set socket options from a single function easily. When those proved unnecessary, the skeleton was left just in case.
Understood, but I thought the body of the function could be simplified like this: static int Dpi_make_socket_fd() { return socket(AF_INET, SOCK_STREAM, 0); } Cheers, Johannes